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Chapter 1  

Introduction 

The Online Marketing Suite Cookbook contains instructions for marketers and content 
authors working with Sitecore Analytics. This guide contains step by step instructions 
on the key tasks necessary in setting up and configuring Sitecore Analytics on your 
website.  

All of the examples in this cookbook use the Office Core website. This website is 
designed to highlight the functionality available in the Online Marketing Suite.  

You can download the Online Marketing Suite Cookbook and Office Core website 
from the Sitecore 6 References section of the Sitecore Developers Network. 

This cookbook contains the following chapters: 

¶ Chapter 1 ð Introduction 
This chapter is a description of the content, aims, and the intended audience of this 
cookbook.  

¶ Chapter 2 ð Creating and Configuring Analytics 
This chapter provides step by step instructions on how to create profiles, goals, 
campaigns, multivariate tests, and personalization. It also includes instructions on 
configuring these items in the Page Editor. 

¶ Chapter 3 ð Assigning Analytics Values to Content Items 
This chapter provides step by step instructions on how to assign profile values to 
content items, how to associate goals and campaigns with content items, and how to 
assign events, failures, and settings. 

¶ Chapter 4 ð Analytics Reporting 
This chapter provides information about the Sitecore standard reports as well as how 
to filter reports. 
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Chapter 2  

Creating and Configuring Analytics 

This chapter provides step by step instructions on how to create and configure 
analytics items in the Online Marketing Suite, Marketing Center. 

This chapter contains the following sections: 

¶ Content Profiling 

¶ Creating Goals 

¶ Testing 

¶ Personalization 
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2.1 Content Profiling 

Content profiles enable you to gain a better understanding of the behavior and actions of your website 
visitors. 

Marketers create content profiles and profile keys in the Marketing Center and content authors use 
the Content Editor to assign values the contents of each web page.  

When visitors come to your website they accumulate a profile score for each visit. This profile is 
based on the values assigned to the content that they view and is recorded in the session trail.  

Profiles 

Creating profiles and profile keys enables you to categorize the content on your website. So when 
visitors navigate through your site they accumulate a score that gives you an insight into the kind of 
content that they are interested in.  

Profile scores can be viewed as a bar chart in the session trail. This information helps content authors 
to identify areas for improvement on the site. It can also be used for segmenting site visitors and to 
create rules for personalization. 

Scores 

Scores give you an insight into a visitorôs level of interest in a website. For example, assigning a high 
lead score to an item, such as a brochure download page means that if a visitor views this page they 
have demonstrated a high level of interest in buying, so can be targeted as a potential sales lead. 

This information can be particularly useful to sales teams. For instance, lead scores can give an 
indication of future customers and sales.  

Examples of scores: 
 

Score Example 

Lead Pages related to price carry a high lead score on your website.  
Knowing which visitors achieve a high lead score could help a 
sales team to target potential new customers. 

Investor A visitor has viewed the annual report page on your site. 
Assigning this page a high investor score could indicate which 
visitors are interested in investment. 

Big spender Assigning a high score to page that records the total purchase 
amount of visitors on your site could indicate which visitors are 
the biggest spenders.  

The Office Core website is configured to record Lead scores to demonstrate this concept. The deeper 
a visitor navigates into the site, the higher their lead score. There are some exceptions to this rule, 
such as downloading a brochure which carries a higher lead score. In Sitecore Analytics, the lead 
reports are stored under the Sales node and the lead scores of each visitor are shown in the session 
trail. 

2.1.1 Pre-requisites 

Before you assign profile values to content items you should consider creating: 

¶ Website personas. 

¶ A profiling strategy. 

¶ A scoring strategy. 
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2.1.2 Creating Profiles 

To create a new profile: 

1. Click the Sitecore menu and then click Marketing Center. 

2. In the Marketing Center, click Profiles.  

3. In the Home tab, in the Insert group, click Profile to create a new profile definition item.

 

4. Give the profile a name, such as, Focus. 

5. In the Profile item, enter the appropriate field values. 

 

 

Field Value 

Name The name of the profile, such as, Focus. 

Type Select one of the following methods of calculation: 

¶ Average 

¶ Percentage 

¶ Sum 

This determines how profile values are calculated. 

6. In the Home tab, click Save. 

7. Click the Publish tab and then in the Publish group click Publish, Publish Item to publish 
the new profile.  
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8. In the publishing wizard, select the Smart Publish option 

2.1.3 Creating Profile Keys 

To create a new profile key: 

1. In the Marketing Center, select a profile such as Focus.  

2. In the Insert group, click Profile Key to create a new profile key definition item. 

Each profile can have any number of profile keys. 

3. Give the profile key a name, such as, Background. 

 

4. In the new Background item, enter field values. 

 
 

Field Value 

Name A name for the profile key, such as, Background. 

Control Select the type of control to appear in the Profiles dialog box: 

¶ Checkbox 

¶ Slider 

¶ Smileys 

¶ Stars 

¶ Text 

MinValue Enter a numeric value, such as, 1. 
This field can also be left blank.  

MaxValue Enter a numeric value, such, as 10. 
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5.  In the Content Editor ribbon, click Save. 

6. Publish the new item. In the publishing wizard, select the Smart Publish option. 

Note 
In the Sitecore Analytics training website there are four pre-configured profiles. Each profile 
has its own set of profile keys. You can extend or delete these profile keys as appropriate for 
your site. 

You can create any number of profiles and profile keys but it is worthwhile planning a profiling 
strategy before you start creating profile definition items. 
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2.2 Creating Goals  

Creating goals and campaigns enables you to measure the success of your website.  

Examples of goals:  

¶ Download a brochure 

¶ Register for an e-mail newsletter 

¶ Sign up for an online demo 

Once you have created some goals you can measure the conversion rate for each goal (the 
percentage of visitors that achieve a particular goal). The website performance reports show goals 
and conversion rates. 

To create a new goal: 

1. Click the Sitecore button and then click the Marketing Center. 

2. In the Marketing Center, click Goals.  

3. In the Home tab, Insert group, click Goal to create a new goal definition item.

 

4. Give the goal a name, such as, Register. 

5. In the new goal definition item, enter the appropriate values. 
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Field Value 

Name Enter a name of your goal, such as, Register  

Icon Select an icon for your goal.  
Click Open icon and select an icon in the Open File dialog box. 
 
To upload an icon of your own, click Upload in the Open File 
dialog box. 

Description Enter a suitable description, such as, User has registered. 

IsSystem This defines the event as a system event. 
For administrators and advanced users only. 

IsAuthorFeedback Select this checkbox to provide the content author with feedback 
on goals. 

IsGoal Select this checkbox to ensure that the goal appears in the Content 
Editor, Goals dialog box. You can then associate the goal with a 
content item. 

IsFailure Select this checkbox to define the event as a failure.  
For administrators and advanced users only. 

6. Click Save to save the new goal. 

7. Publish the new goal item. In the publishing wizard, select the Smart Publish option. 
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2.3 Creating Campaigns 

A campaign is a promotion or advertising initiative designed to encourage people to come to a 
website and perform desired actions. 

Sitecore Analytics supports two types of campaigns: 

¶ Online Campaigns 

¶ Offline Campaigns  

You can view reports that show which of your campaigns are the most successful. You can then 
improve or drop unsuccessful campaigns and improve your ROI. 

You create goals and campaigns in the Marketing Center. You associate goals and campaigns with 
content items in the Content Editor. 

To create a campaign: 

1. In the Marketing Center, click Campaigns, and then in the Home tab, in the Insert group, 
click Campaign.  

2. Give your new campaign a name, such as, Google AdWords Campaigns and click OK. 
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3. In the new campaign item, enter the appropriate values. 

 

 

Field Value 

Title The title of the campaign. 

Type The type of campaign ð whether it is an online or offline campaign. 

Description A longer description of your campaign. 

Cost Monetary cost of the campaign. 
For example, Google AdWords campaigns have a cost per click. 

StartDate The start date for the campaign. 

EndDate The end date for the campaign. 

Hidden Whether or not the campaign should be shown in reports. 
For example, you may not want to show campaigns that are 
created automatically in your campaign reports. 

4. Click Save to save the new campaign. 

5. Publish the new campaign item. In the publishing wizard, select the Smart Publish option. 

2.3.1 Creating Campaign Events 

To create a campaign event: 

1. In the Marketing Center, select a campaign item and then in the Home tab, in the Insert 
group, click Campaign Event. 

2. Give your new campaign event a name, such as Award Winning Campaign and click OK. 
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3. In the new item, enter the appropriate field values.

 

 

Field Value 

Name The name of the campaign. 

Campaign Link This field contains a campaign query string.  
For example: 
sc_camp=7F967B85B627472AABE83F5F3DA51421  

Append the query to the link to your website provided on the 
sponsored site. If the link already includes a query string, prefix the 
provided text with an ampersand (&). If the link does not include an 
existing query string, prefix the text with a question mark (?).  
This ensures that site visits generated by this campaign are 
recorded in the analytics system. 

4. Click Save to save the campaign event. 

5. Publish the new campaign event item. In the publishing wizard, select the Smart Publish 
option. 
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2.4 Testing  

Sitecore Analytics lets you dynamically test the content of your website to find out which web controls 
are the most effective.  

You can create multivariate tests to see which combinations of text and images work best with site 
visitors. This can be particularly useful as a part of your strategy when setting goals and optimizing 
campaigns.  

The Sitecore Analytics MV Tests report gives you pre-configured statistics on your tests and includes 
data on the number of conversions that result from each test. 

2.4.1 Pre-requisites 

Before you can create a multivariate test, you need: 

¶ Two or more content items to use as test variables. 

¶ A control to use as the data source for your test. 

2.4.2 Creating Multivariate Tests 

In the following example, you will create a multivariate test for a newsletter form. Visitors to your 
website complete this type of form to register for an e-mail newsletter. In this multivariate test, you test 
three different combinations of text and graphics to find out which is the most effective. 

To create a multivariate test: 

1. Click the Sitecore button, and then click Marketing Center. 

2. In the Marketing Center, click Test Lab. 

 

3. In the Home tab, in the Insert group, click Multivariate Test to create a new multivariate test 
definition item. 
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4. Call your test Newsletter Form. 

 

5. In the new test item, enter the appropriate field values. 
 

Field Value 

Title The title of the test, such as Newsletter Form. 

Description A description of the test. 

Test Strategy Select a test strategy: 

¶ Random ð the test variable changes for each page 
request 

¶ Sticky ð the test variable changes for each visitor session 
(recommended) 

6. Click Save to save the new test. 

2.4.3 Creating Multivariate Test Variables 

Each multivariate test must have at least two test variables. Each variable represents an item of web 
content that you want to test. These content items must be created already. 

Create three test variables for the Newsletter Form test: 

1. In the Marketing Center, select the Newsletter Form multivariate test that you created earlier.  
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2. In the Home tab, in the Insert group, click Multivariate Test Variable to create a new test 
variable.  

 

3. For this example, create the following three multivariate test variables: 

o Big-Check 

o Medium-Arrow 

o Small-Red 

 

4. For each variable enter the following field values: 
 

Field Value 

Name A suitable name for the test variable. For example, Big-Check. 

Data Source A link to the content item that is the data source for this test 
variable, for example: 
sitecore/content/Home/Standard - Items/Register -

Form/Big - Check  

5. Click Save to save the test variable. 

6. Repeat this procedure for each test variable.  
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Link each variable to one of the content items that you want to test. 

7. Publish the new test variables. In the publishing wizard, select the Smart Publish option. 

2.4.4 Configuring Multivariate Tests 

To activate a multivariate test on your website, you must edit the layout properties of the page where 
you want to place the test. You can do this in the Page Editor or in the Content Editor.  

Configuring Multivariate Tests in the Page Editor 

1. In the Sitecore Desktop, click Sitecore, and then click Page Editor. 

2. In the Page Editor, navigate to the page that you want to place the test on. In this case, the 
Home page.  

3. Click the Toggle the ribbon button  to display the ribbon. 

4. In the ribbon, click the View tab and in the Enable group, select the Designing check box to 
enable the design functionality in the Page Editor. 

5. On the Home page, select the Register for our Newsletter item to see the design options for 
this item. 
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6. Click the Properties button  to open the Properties dialog box for this control. 

 

7. In the Properties window, scroll down to the Test Lab section, and select the Newsletter 
Form test. 

8. Click OK. 

9. In the Page Editor, click Save. 

Now when a visitor comes to the website, a register form control is displayed on the home page. The 
same register form control is displayed for the entire duration of the browser session. When a visitor 
closes the browser window, they end the session. When a visitor returns to start a new session, a 
different register form variable is displayed.  

This enables you to test each variable so you can find out which control is the most effective. 

Sitecore Analytics contains an MV Test report that lets you evaluate your multivariate tests. This 
report includes the following information: 

¶ Summary data for each test. 

¶ Percentage of session visits per test variable. 

¶ Number of session visits per test variable. 

¶ Percentage of session conversions per test variable. 

¶ Number of session conversions per test variable. 
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2.5 Personalization 

Personalization allows you to deliver targeted content to specific site visitors. An appropriate time to 
implement this is after segmentation has enabled you to identify the visitors that you most want to 
target. 

You can create rules to show or hide content to site visitors based on their browsing behavior and 
accumulated profile values.  

You can make your site respond in real-time by showing or hiding content, adjusting the behavior of a 
web control or by running a multivariate test. 

2.5.1 Pre-requisites 

Before you can create personalization rules you need the following components: 

¶ Content items to use as the data source for the conditional renderings. 

¶ A Web control or rendering item. 

2.5.2 Creating Personalization Rules 

In Sitecore Analytics, you can create rules to determine which content is shown to different site 
visitors. This is called conditional rendering. You create conditional rendering rules in the Marketing 
Center. 

To create a conditional rendering rule: 

1. Open the Marketing Center. 

2. In the content tree, click Personalization and then click Rules. 

 

3. To create a new rule, in the Home tab, in the Insert group, click Conditional Rendering Rule. 

4. Give the rule a name, for example, Show Brochure to Leads and then click Save. 

5. In the new rule item, in the Name field, enter the name of the rule. This is the same name that 
will appear in the Designer when you configure your rule. 



Sitecore OMS 1 Online Marketing Suite Cookbook   

 

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The 
contents of this document are the property of Sitecore. Copyright © 2001-2010 Sitecore. All rights reserved.  

Page 21 of 55 

6. In the Rule field, click Edit Rule. 

 
7. In the Rule Set Editor dialog box, select a condition and an action for your rule. 

 

Rules Example 

This example demonstrates how to create a rule that determines when new site visitors will see the 
Office Core brochure link. 

On the Office Core site, a brochure download link is displayed on every page, apart from the home 
page. This rule will specify that the brochure link on the Our Services page is not displayed to new 
visitors unless they attain a lead score of 20 or more. 

1. In the Marketing Center, create a new rule called Hide for New Visitors. 

2. In the Hide for New Visitors item, in the Rule field, click Edit Rule to open the Rule Set 
Editor dialog box. 
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3. In the Rule Set Editor dialog box, in the Select the conditions for the rule section, scroll 
down and select the following rule: 

ñWhere the value of specific profile key compares to specific valueò  

This rule is now displayed in the Rule description section.  

 

Now you must edit the values in this condition so that only visitors who have accumulated a 
lead score of 20 or more can see the brochure download link.  

4. In the Rule description section, click ñspecificò to open the Select Profile Key dialog box.  

 

5. In the Select Profile Key dialog box, expand Score and select Lead. 

6. In the Rule Set Editor dialog box, in the Rule description section, click ñcompares toò, to 
select a comparison to use in this rule.  

7. In the Select Comparison dialog box, select ñis less than or equal toò and click OK. 

 

8. In the Rule Set Editor dialog box, in the Rule description section, click ñspecific valueò, to 
enter a numerical value.  

In this example, you want the brochure download link to be displayed on the Our Services 
page when the Lead profile score is higher than 20. 



Sitecore OMS 1 Online Marketing Suite Cookbook   

 

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The 
contents of this document are the property of Sitecore. Copyright © 2001-2010 Sitecore. All rights reserved.  

Page 23 of 55 

Enter ñ20ò and click OK.  

 

9. In the Rule Set Editor dialog box, in the Select the actions for the rule section, select one 
of the pre-configured actions for your rule.  

In this example, select ñhide renderingò. 

 

10. In the Rule Set Editor, click OK to save the rule. 

11. In the Marketing Center, click Save and then publish the new rule. In the publishing wizard, 
select the Smart Publish option. 

2.5.3 Configuring Personalization Rules 

To activate a personalization rule on your website, you must edit the layout properties of the page you 
want to personalize. There are two ways to do this. 

¶ In the Content Editor, use the Presentation tab, Layout Details dialog box. 

¶ In the Page Editor, use the Designing mode. 
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Configuring Personalization Rules in the Page Editor 

1. In the Sitecore Desktop, click Sitecore and then click Page Editor. 

2. In the Page Editor, navigate to the page that you want to edit.  

In this example, edit the Our Services page.  

3. In the ribbon, click the View tab and in the Enable group, select the Designing check box to 
enable to the design functionality in the Page Editor. 

4. Select the Brochure Links control and click Properties  to open the Properties dialog box. 

 

5. In the Properties window, scroll down to the Personalization section.  

 

6. Select the rule you created called ð Hide for New Visitors. 

7. Click OK to close the Properties window. 

8. In the Page Editor, click Save.  
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Testing the Rule 

To test that the rule works: 

1. In a new browser window, open the Office Core website.  

2. Navigate to the Our Services page.  

Notice that there is no longer a brochure displayed in the right-hand column.  

3. Explore the site a little more and return to the Our Services page.  

Once you have accumulated a lead score of 20 or more, the brochure link will appear in the 
right-hand column. 
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Chapter 3  

Assigning Analytics Values to Content Items 

This chapter tells you how to assign profile values and scores to content items using 
the Content Editor or the Page Editor. It also explains how to associate Sitecore 
Analytics items with content items. 

¶ Assigning Values to Profiles and Scores 

¶ Associating Goals with Items 

¶ Associating Campaigns with Content Items 

¶ Assigning Events to Items 

¶ Assigning Failure Actions to Items 

¶ Analytics Page Settings 
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3.1 Assigning Values to Profiles and Scores 

Once you have created a set of profiles and profile keys you can start to assign values to content 
items on your website. You assign values to profile keys in the Content Editor or Page Editor. 

3.1.1 Assigning Profile Values to Content Items in the Page Editor  

1. Open the Page Editor and in the Office Core website, navigate to Our Services. 

2. In the Page Editor, Advanced tab, Analyze group, click Profiles to open the Profiles dialog 
box. 

 

3. In the Profiles dialog box, select the Focus check box and move the slider controls to assign 
values to each profile key. 

 

You have now assigned values to the Focus profile. 

4. Repeat this procedure for each profile key.  

Note  
Profile key values can be left blank if they are unsuitable for a content item. 
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5. When you have finished assigning values to profile keys, click OK to close the Profiles dialog 
box and to save your changes.  

Note 
If you do not select the check box next to a profile key first before editing it, the values are not 
saved. 

3.1.2 Assigning Scores 

You also use the Profiles dialog box to assign scores to content items in the same was as you assign 
profile values to content items. 

 

3.1.3 Assigning Profile Values to Content Items in the Content Editor 

You can also use the Content Editor to assign profile values to content items. 

To assign profile values to content items in the Content Editor: 

1. In the Content Editor, expand the content tree and locate the item that you want to assign 
profile values to. 

2. In the Analyze tab, in the Attributes group, click Profiles to open the Profiles dialog box. 

 

3. In the Profiles dialog box, repeat the procedure described in the previous section. 
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3.2 Associating Goals with Items 

After you create a goal in the Marketing Center, you must associate the goal with a content item.  

When a visitor navigates to a page that has a goal assigned to it, a conversion is recorded in Sitecore 
Analytics. 

In this example, you assign the Register goal to the Home item. 

How to associate a goal to a content item: 

1. Open the Content Editor.  

2. Navigate to the Home item.  

3. Click the Analyze tab and then in the Attributes group, click Goals. 

 

4. In the Goals dialog box, select the Register goal.  

5. Click OK to save your changes. 

You have now assigned the Register goal to the Home item. 
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3.3 Associating Campaigns with Content Items 

After creating a campaign in the Marketing Center, you must ensure that the campaign is triggered in 
Sitecore Analytics so you can track which campaigns your site visitors have come from. 

Online Campaigns 

An online campaign consists of a campaign definition item and a campaign event. To associate an 
online campaign with a content item, you must copy the campaign query string to the sponsored site 
and if necessary edit the query string to point to a page on your website. 

How to associate an online campaign with a content item: 

1. Open the Marketing Center.  

2. Expand the Campaigns node and then click the Google AdWords Award Winning Campaign. 

 

3. In the Campaign Link field, copy the query string. 

4. Paste the query string to your sponsored site. 

This example uses a Google AdWords campaign. 

5. Paste the campaign query string into your sponsored site. 

 

You must append the query string to your site URL. In this example the website URL is: 

www.sitecore.net/default.aspx   

The query string provided for this campaign is: 

sc_camp=E0E6A1A02F5342F1BC30DABCC3670A20 

After you insert the query string, you must insert a question mark to complete the path, as this 
is not included in the Campaign Link field: 

www.sitecore.net/default.aspx?sc_camp=E0E6A1A02F5342F1BC30DABCC3670A20  
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6. By default the campaign query string links to your home page. To point to a different page, 
you must edit the query string.  

For example, you could replace /default.aspx?  with /Our - Services.aspx?  

 

When a visitor comes to your website from this campaign, a campaign event is triggered in Sitecore 
Analytics, and this is recorded in the Latest Human Sessions report.  

Offline Campaigns 

An offline campaign consists of a campaign definition item, a campaign event, and a landing page 
that can be reached using an alias. 

To activate an offline campaign, you use the Content Editor to associate the campaign event with a 
landing page. In this example, you associate the AD08 campaign with the Architectural-Digest-May-08 
landing page. 

To associate an offline campaign with a landing page: 

1. Open the Content Editor. 

2. In the Content Editor content tree, navigate to the Standard-Items folder. Open the Landing-
Pages folder and then select the Architectural-Digest-May08 content item. 

3. In the Analyze tab, in the Attributes group, click Attributes to open the Attributes dialog 
box. 

 

4. In the Attributes dialog box, select the AD08 campaign.  

5. Click OK. 

Now when visitors come to your site from this campaign, a campaign event is triggered and this is 
recorded in the Latest Human Sessions report in Sitecore Analytics. 



Sitecore OMS 1 Online Marketing Suite Cookbook   

 

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The 
contents of this document are the property of Sitecore. Copyright © 2001-2010 Sitecore. All rights reserved.  

Page 32 of 55 

3.4 Assigning Events to Items 

Events are used to track user activity on a website. They help to build up a more comprehensive 
picture of a visitorôs behavior as they navigate through the website. 

Goal and campaign events are triggered when visitors achieve certain objectives on the website or 
when they come to a site from a promotion or campaign that you have created. These events are 
tracked in Sitecore Analytics and appear in the campaign and conversion tracking reports. 

You can also associate other events with content items. You can track events, such as, download, 
search, registration or logout. Sitecore administrators can create additional events if needed. 

To assign an event to a content item:  

1. In the Content Editor, expand the content tree and navigate to the content item that you want 
to assign an event to.  

2. In the Analyze tab, in the Attributes group, click Attributes to open the Attributes dialog 
box. 

3. In the Attributes dialog box, click the Events tab, and select the event that you want to 
assign to the content item. 

 

4. Click OK to save your changes and close the Attributes dialog box.  
















































